Peters Flexible RenAmiNg Kit (PFrank) Forum Index Peters Flexible RenAmiNg Kit (PFrank)
Support and Discussion Site for the PFrank File/Folder Renaming Tool (http://www3.telus.net/pfrank)
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Help with Unicode

 
Post new topic   Reply to topic    Peters Flexible RenAmiNg Kit (PFrank) Forum Index -> General Support
View previous topic :: View next topic  
Author Message
ssjkakaroto



Joined: 09 Mar 2007
Posts: 16
Location: BR

PostPosted: Sat Mar 10, 2007 5:44 pm    Post subject: Help with Unicode Reply with quote

Hi, I have a file named ドラゴンボールZ BGMコレクション CD-BOX.log and when I try to replace レクション with test Pfrank says that there are no matches, the Unicode codec is set to input Auto-detect and output default. I tried selecting utf-8 and shift-jis but the result is the same.

Thanks
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 09 Mar 2007
Posts: 446
Location: Canada

PostPosted: Sat Mar 10, 2007 5:52 pm    Post subject: Reply with quote

I used your example unicode text, created a file with the same name and had no trouble using PFrank to rename it.
My unicode input/output settings are both set to 'default'. You shouldn't have to change those settings except for specialized cases.

What kind of o/s are you using? I carried out my test on Windows XP SP2.
Is your name filter set to '*'? Otherwise you might be doing some unintended filtering.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ssjkakaroto



Joined: 09 Mar 2007
Posts: 16
Location: BR

PostPosted: Sat Mar 10, 2007 6:35 pm    Post subject: Reply with quote

Now I can reply Wink
I'm using Windows XP SP2 too and the name filter is set to '*'.
Take a look at the log
Quote:
==========================================================================
Mar 10 2007 15:00:23 ***Scan Complete

'Custom' Replacement Summary:

Row: 1
Search: '?????'
Replace: 'test'

Current Folder: 'J:\dbz bgm\cd1\eac'

Total Names to be Changed: 0
Total Names Scanned (after Filtering): 2

See the ?????
Do I need any special command so that the unicode characters get recognized?
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 09 Mar 2007
Posts: 446
Location: Canada

PostPosted: Sat Mar 10, 2007 6:55 pm    Post subject: Reply with quote

I noticed my summary log had the questions marks as well. Then I changed the Unicode file exporting option to utf_16. After that the summary file was ok. I had forgotten about the need to set the export option for asian characters. My summary output is now:

Row: 1
Search: 'レクション'
Replace: 'test'

Current Folder: 'C:\Documents and Settings\peter\Desktop\neftest'

Total Names to be Changed: 1
Total Names Scanned (after Filtering): 20

Is your Unicode import option set to 'default'? If it still doesn't work with the default setting, then please send me the PFrank.log text file which should be found in your 'Application Data/PFrank' folder. Maybe there's some information in there that might help.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ssjkakaroto



Joined: 09 Mar 2007
Posts: 16
Location: BR

PostPosted: Sat Mar 10, 2007 8:04 pm    Post subject: Reply with quote

Now the summary log is ok too but it still won't rename Sad

Here's the last output of Pfrank.log
Quote:
PFrank 1.91
Windows O/S is: Windows-XP-5.1.2600-SP2 (2)
Starting main loop at Mar 10 2007 17:00:49
App data folder is: 'C:\Documents and Settings\Administrator\Application Data'
PFrank initiated from command line:
C:\Program Files\PFrank\PFrank.exe
J:\dbz bgm\cd1\eac
PFrank executing out of folder: J:\dbz bgm\cd1\eac
Locale is: ('en_US', 'cp1252'), Default Codec is: 'cp1252'
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 09 Mar 2007
Posts: 446
Location: Canada

PostPosted: Sun Mar 11, 2007 12:32 am    Post subject: Reply with quote

Good news. I've reproduced the problem.
It's totally bizarre and I can't explain it at this point but I have a work-around.

First, the PFrank.log file showed that you started the session with a right click of a folder.
I then started PFrank by right clicking on a folder, dragged the folder with the asian-named file to it, and had no trouble performing the renaming.
I then terminated the session and restarted it by right clicking on the folder with the asian-named filename. Tried the renaming and it failed!!
Restarting with quicklaunch or the start menu after that failed to fix the problem.

But there are some work-arounds.
1)
If you reset all the configurations (Pull down the File menu on the main window and choose 'Reset"), then you can do the unicode renaming. But you loose all your setitngs.
2)
A more preferrable way is to simply drag the folder with the asian-named file into the current folder panel. I found that the scan worked after that.

Let me know if the second (or the first if you prefer) work-around is successful for you.

Thanks very much for letting me know about this problem!
Now I have to figure out what's wrong and fix it :(

One other point just for clarification. Changing the unicode export setting was only required to make the asian characters appear properly in the summary log. It has nothing to do with the scan results.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ssjkakaroto



Joined: 09 Mar 2007
Posts: 16
Location: BR

PostPosted: Sun Mar 11, 2007 5:43 am    Post subject: Reply with quote

Using the method you mentioned worked flawlessly Wink
Now I hope you can find the cause of it.
Can you add some sort of auto detection of character coding to the output too? This way if we leave Default on both output and input will display the correct characters.

Thanks a lot for the help.
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 09 Mar 2007
Posts: 446
Location: Canada

PostPosted: Sun Mar 11, 2007 7:13 am    Post subject: Reply with quote

I've fixed the problem. The fix will be available in the next version.
Thanks for alerting me to this problem and for providing the information to help track this down.

As for the auto-detect on output question, PFrank will create files based on what the Locale setting is. In your case it's en_US. That's why the summary panel (which is really a file) couldn't show asian characters with the default setting.
One solution I considered originally was to always write the summary file in unicode. Instead I made the unicode export option so that people can override the default output format.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
admin
Site Admin


Joined: 09 Mar 2007
Posts: 446
Location: Canada

PostPosted: Wed Apr 11, 2007 4:34 am    Post subject: Reply with quote

This has been fixed in version 1.94.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
bigboxred



Joined: 18 Jun 2008
Posts: 4

PostPosted: Wed Jun 18, 2008 4:18 pm    Post subject: Replacing asian characters with ascii Reply with quote

Hello,
the product is absolutely great, but I'm struggling to find a way to replace anything non-ascii (especially asian characters) with ascii characters or a simple number sequence, while preserving the extension.

What I need is the following... I want PFrank to detect files like:

- 配件成本外贸报价.xls and rename it to asianfile001.xls
- 08류성용.xls and rename it to asianfile002.xls
- _DSC0023挖.jpg and rename it to asianfile003.jpg

etc....

Could anyone please show me the light? I've tried for a while already but cannot find the way to do this.
Thank you in advance for your help!
Alex
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 09 Mar 2007
Posts: 446
Location: Canada

PostPosted: Thu Jun 19, 2008 3:42 am    Post subject: Reply with quote

I already replied to this question in the following thread:

http://pfrank.s4.bizhat.com/viewtopic.php?t=134

Peter.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
carlyse_09
Guest





PostPosted: Thu Dec 18, 2008 6:23 am    Post subject: Reply with quote

Im happy to hear that the problem was now fix.Im excited to see the next version and know more about it.
Back to top
Display posts from previous:   
Post new topic   Reply to topic    Peters Flexible RenAmiNg Kit (PFrank) Forum Index -> General Support All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group. Hosted by phpBB.BizHat.com


Start Your Own Video Sharing Site

Free Web Hosting | Free Forum Hosting | FlashWebHost.com | Image Hosting | Photo Gallery | FreeMarriage.com

Powered by PhpBBweb.com, setup your forum now!
For Support, visit Forums.BizHat.com